Error:
Settlement not found on your Amazon Seller Central. Please re-verify it or download settlement by date range.
Cause of the issue:
This issue typically arises when trying to re-download an existing Amazon Settlement Report in Webgility Desktop. This error indicates that Amazon is not providing the Amazon Settlement Report in the response and returning with this error.
Steps to fix:
If the settlement report is partially posted, undo the sync
Once done then select the settlement report, navigate to Remove Settlement symbol and click on it.
This will open a popup so click on Remove From Webgility and complete the step.
Now try to download the settlement report again.
Follow the steps in this helpful article on how to download Amazon Settlement Report
Note: If required you can also manually import the Amazon Settlement Report. Follow the steps in this helpful article on How to Manually Import an Amazon Settlement Report
If the problem persists, contact Webgility Support for further assistance.