Error:
Date or amount does not match with the payment transaction attached with Invoice but the GUID matched.
Cause of the issue:
This issue typically arises when trying to post Amazon Settlement Report into Quickbooks. The error indicates the data related to Date and amount is not matching between the Order and its respective Amazon report available in Webgility Desktop. In such cases, the settlement and order data need to be redownloaded before posting to QuickBooks.
Steps to fix:
Note the affected order number by copying the error message, (click on the error, press Ctrl + C, then paste it into a Notepad file using Ctrl + V),
Navigate back to Dashboard and search for this order in all relevant tabs like ‘Posted orders’ or ‘Archived’.
If the order is already posted to Quickbooks, undo sync the order and then re-download it.
Follow the steps in this helpful article to Undo Sync an order in Webgility Desktop
Follow the steps in this helpful article to Redownload an order in Webgility Desktop
Once done then navigate back to Dashboard, click on Orders options in the menu, goto Amazon and click on Settlement Report. If the Settlement report is partially posted, Undo Sync it. Then goto the Remove button, click on it. A popup will open asking you to Re-Download. So click on it and wait for the success message.
Once done then try to post the Settlement Report again.
If the problem persists, contact Webgility Support for further assistance.