Skip to main content
All CollectionsWebgility DesktopAdvice & troubleshootingFees & Payouts
Error while add payment for Settlement as few invoices QBTxnID Not Found in QuickBooks

Error while add payment for Settlement as few invoices QBTxnID Not Found in QuickBooks

Learn how to solve error "Error while add payment for Settlement as few invoices QBTxnID Not Found in QuickBooks"

Devendra Singh avatar
Written by Devendra Singh
Updated this week

Error:

Error while add payment for Settlement, as few invoices QBTxnID Not Found in QuickBooks

Note: This error is specific to an Amazon Sales Channel & Settlement posting scenario.


Cause of the issue:

This error typically occurs during the “Post Payments” step while posting an Amazon settlement report. This means one or more transactions (invoices) are missing or deleted from QuickBooks, preventing Webgility from applying payments. Below are some reasons why this can happen:

  • The order(s) listed in the settlement report were previously posted to QuickBooks.

  • But later, the corresponding transactions were manually deleted or removed in QuickBooks.

  • Without the transaction's QuickBooks ID (TxnID), Webgility cannot apply payment during settlement processing.


Steps to fix:

1. Locate the Error

  • In Webgility, go to the Post Settlement screen. Click on the Red i button and find the last step, “Error on Post Payment”. Double-click on it to open the detailed error window.

2. Copy Order Numbers

  • Click anywhere on the order number in the error message. Press Ctrl + C to copy all order numbers. Open Notepad (or any text editor), then press Ctrl + V to paste the list for easy reference.

3. Check Orders in Webgility

  • One by one, search each order in the Webgility Desktop under the Posted or Archived tab. Then open the order details and click “View in QuickBooks”. If you see “QBTxnID not found in QuickBooks”, the original transaction is missing.

4. Re-download the Affected Orders

  • For the orders found inside QuickBooks, first undo the sync and then redownload them.

  • For the orders that are missing transactions inside QuickBooks, you can directly perform a redownload on them.

Follow the steps in this helpful article on Order Re-download in Webgility Desktop

5. Retry Settlement Posting

  • Navigate back to Orders in the menu options, then go to Amazon and click Settlement Report.

  • Select the Settlement report again and click “Post to QuickBooks” again.

Tip: Avoid deleting Sales Receipts or Invoices directly in QuickBooks that are linked to Webgility


If the problem persists, contact Webgility Support for further assistance.

Did this answer your question?