Error:
Error while creating payment in QuickBooks. The ticket parameter is invalid.
Cause of the issue:
This issue usually occurs when trying to post orders from Webgility Online into QuickBooks Desktop. This error indicates that the latest accounting data needs to be updated in Webgility Online, and the settings need to be saved again.
Steps to fix:
Verify and confirm if Webgility Online is connected to QuickBooks Desktop. For that, make sure Webgility Extension is up and running and the QuickBooks connection status is showing a green check mark at the top of Webgility Online UI.
Now refresh the accounting data in Webgility Online.
Follow the steps in this helpful article on Download the Latest Data from QuickBooks in Webgility Online
After refreshing data. Save the settings and then try to post the order again.
Tip: In rare scenarios, you might see a QuickBooks unrecoverable error. Simply close both Webgility Extension and QuickBooks Desktop and then relaunch them. Then run “manual sync” on Webgility Extension, and this will resolve the issue.
If the problem persists, contact Webgility Support for further assistance.