Error:
Post to Quickbooks failed due to There was an error when saving a customer's list element. Quickbooks error message: This list has been modified by another user
Cause of the issue:
This error typically occurs when trying to post the orders into QuickBooks. The error indicates that there is a mismatch of accounting data between the Webgility Desktop database and QuickBooks. It can be items, customers, vendors, accounts, etc, for this case it is Customers data. This typically happens when other add-on QuickBooks users are working in the company file while Webgility Desktop is trying to post the orders.
Steps to fix:
Regular accounting data refresh in Webgility Desktop:
In Webgility Desktop navigate to Connections and then click on “Get Latest Data and Settings”
Now under “Download QuickBooks data and settings” click on Download Data and wait for the process to complete.
Once done then try to post the order again.
Refreshing accounting data from scratch in Webgility Desktop:
In case the issue still persists then you can try refreshing the Quickbooks accounting data from scratch in Webgility Desktop.
Follow the steps in this helpful article on How to Download the Latest Accounting Data from Scratch - Webgility Desktop
If the problem persists, contact Webgility Support for further assistance.