Error:
Order has item overpayment which not found in quickbook
Cause of the issue:
This issue usually occurs when the payout posting process attempts to post an order to QuickBooks, but an item within that order is not found in QuickBooks.
Steps to fix:
Take note of the order number and search under the “ New orders” tab.
Select the order and click on “post to Quickbooks.”
You’ll receive a prompt as shown in the screenshot below.
Click " OK " to get to the popup window as shown in the screenshot below.
Now as per your need you can create a new item OR map it to an existing one from QuickBooks.
Follow the steps in this helpful article to create/map items while posting order: How to Map Products While Posting Orders
Once the order has been posted, now try to post the payout again.
If the problem persists, contact Webgility Support for further assistance.