Error:
There was an error when saving a SalesReceipt. QuickBooks error message: You have no items or one or more of your amounts is not associated with an item. Please enter an item
Cause of the issue:
This issue usually occurs when trying to post orders from Webgility Online into QuickBooks. This error indicates that the latest accounting data needs to be updated in Webgility Online, and the settings need to be saved again.
Steps to fix:
Refresh the accounting data in Webgility Online.
Follow the steps in this helpful article on Download the Latest Data from QuickBooks in Webgility Online
After refreshing data, save the settings and then try to post the order again.
If the problem persists, contact Webgility Support for further assistance.