Error:
There is an invalid reference to the payment method "unknown" in the received payments. Quickbooks Error Message: Invalid Argument. The specified record does not exist in the list.
Cause of the issue:
This issue typically arises when trying to post Shopify Payout into QuickBooks. The error indicates that the required order contains payment method “unknown” which is not matching to any existing payment methods available inside Quickbooks and thus results in an error. This usually happens when Order at Sales channel were paid either by Cash or any other means and due to that there is no specific payment method available on the same.
Steps to fix:
Map Payment Method with QuickBooks
You will need to add the payment method “unknown” in Webgility Desktop and then map it with the required payment method from Quickbooks.
Follow the steps in this helpful article on adding and mapping “unknown” payment method
Once done then try to post the Payout again.
If the problem persists, contact Webgility Support for further assistance.