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Order already posted in accounting so we are not able to find that transaction in accounting and also not able to post the order in accounting.
Order already posted in accounting so we are not able to find that transaction in accounting and also not able to post the order in accounting.

Order already posted in accounting

David Pond avatar
Written by David Pond
Updated today

Error:

Order already posted in accounting so we are not able to find that transaction in accounting and also not able to post the order in accounting.


Cause of the issue:

This issue typically occurs when trying to post an order into QuickBooks. This error indicates that the transaction Webgility Desktop is trying to create for the order is already present inside QuickBooks. This usually happens when the order is redownloaded directly without unsyncing the previously posted transaction in accounting. This leads to issues where the order is not found in accounting and cannot be posted again.

  • Redownloading Orders Without Unsyncing:
    โ€‹If an order is redownloaded without first unsyncing the existing transaction or if the order update is accepted without selecting "Undo Sync" when prompted,

  • Webgility treats the order as new. However, when attempting to post it again, it detects the original transaction in QuickBooks via its internal GUID.


Steps to fix:

1). Check Webgility Order History:

  • Open Order History in Webgility.

  • Find the old invoice number associated with the order.

2). Locate and Delete the Transaction in QuickBooks:

  • Use the invoice number found in Webgility to locate the original transaction in QuickBooks.

  • Delete the transaction in QuickBooks.

3). Repost the Order:

  • After deleting the transaction in QuickBooks, go back to Webgility and try posting the order again.


Permanent Resolution

A customization node can be applied to prevent this error from occurring in the future.

  • On your Webgility Desktop machine navigate to C:\Webgility\UnifyEnterprise\XML

  • Locate the file named apiConfig.xml.

  • Right-click the file, open it with Notepad, and paste the above node into the appropriate section.
    Update the following node in the file โ€œ<CustomizationNode>GUID_EXTRA_FIELD_1</CustomizationNode>โ€

  • Save the file and restart Webgility Desktop.

  • Attempt to post orders again.


If the problem persists, contact Webgility Support for further assistance.

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