Error:
The QuickBooks company data file is currently open in a mode other than the one specified by your application.
Cause of the issue:
This issue typically arises either when trying to connect or posting orders into QuickBooks. This error indicates that the mode of the company file is different when compared between QuickBooks and Webgility Desktop.
Steps to fix:
In QuickBooks, check the title bar. if it says "Multi-User," the company file is in multi-user mode; if there's no message, it's in single-user mode.
You can also verify this under File in the menu. If you see "Switch to Single-User Mode," it's already in multi-user mode, and vice versa.
After verifying the company file mode in QuickBooks, open Webgility Desktop and navigate to Connections then go to Accounting/POS/ERP. Click Edit Connection, select the same QuickBooks file mode, then click Test QuickBooks Connection and save.
Now try to post the order again if it was stuck earlier.
If the problem persists, contact Webgility Support for further assistance.