Error:
This application has not accessed this QuickBooks Company data file before. The QuickBooks administrator must grant an application permission to access a QuickBooks company data file for the first time.
Cause of the issue:
This issue typically occurs when Webgility Desktop is trying to communicate with QuickBooks. So this error can occur while order posting, item download, testing connection, etc. The error indicates that the Webgility Desktop as an application doesn't have the required permissions to access the QuickBooks company file or that the QuickBooks Admin user has recently changed its password. So you will need to re-establish the required permissions for the communication between Webgility Desktop and QuickBooks.
Steps to fix:
Reconnect QuickBooks:
On the Webgility Desktop machine facing this error, log into QuickBooks Desktop as an Admin user. Once done then test the QuickBooks connection from Webgility Desktop. Follow the steps in this helpful article on How to Test QuickBooks Connection in Webgility Desktop
Regenerate QuickBooks Certificate:
If the issue still persists then you can regenerate the QuickBooks connection certificate. Follow the steps in this helpful article to Regenerate QuickBooks Certificate
If the problem persists, contact Webgility Desktop for further assistance.