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Object reference not set to an instance of an object - Shopify connection

Object reference not set to an instance of an object - Shopify connection

Learn how to solve error "Object reference not set to an instance of an object - Shopify connection"

Devendra Singh avatar
Written by Devendra Singh
Updated this week

Error:

Object reference not set to an instance of an object - Shopify connection

Note: This error is specific to the Shopify Sales Channel connection.


Cause of the issue:

This issue typically arises while connecting the Shopify sales channel or reauthorizing an existing integration. This error indicates that the URL provided during the Sales Channel connection is incorrect or invalid. Because of this, Webgility Desktop is unable to create a valid reference to the store object, resulting in this exception.


Steps to fix:

  • Verify Webgility Desktop version

    Ensure that your Webgility Desktop application is running the latest version. Follow the steps in this helpful article on How to Update Your Webgility Desktop Software

  • Verify the correct store URL

    • Log in to your Shopify Channel with Admin user credentials.

    • Once logged in, go to the top-right corner of the page where you’ll see your store’s avatar icon. Click on the icon and select the “Manage account” option.

  • This will redirect you to a new page. Look for the “Stores” section and select the option that says “View all stores”.

  • This will open a new window displaying the URL for your Shopify sales channel.

  • Update the URL in Webgility Desktop and test the connection

    • In Webgility Desktop, navigate to Connections, then go to Sales Channel and click on Manage Sales Channel.

  • This will open a new window, so under the Action column (for the respective Shopify profile), click Edit Connection.

  • This again opens a new window, so update the required part of the URL under Sales Channel Address and click on “Connect to Shopify”.

  • You should now receive a "Connection Successful" message. Click on Next and then Save Store.

This method ensures your connection to Shopify is properly configured, allowing for seamless syncing between Webgility and your Shopify store.


If the problem persists, contact Webgility Support for further assistance.

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