Error:
You need permission to update Webgility x Quickbooks online - App. update at Shopify sales channel
Note: This error is specific to a Shopify Sales Channel
Cause of the issue:
This issue typically occurs when connecting/reconnecting the Shopify sales channel with the Webgility application. This error indicates that there’s a pending update on Webgility’s Third-party Shopify App. on the Shopify Sales Channel. Due to security reasons, the add-on user of Shopify might see this error while reconnecting the Shopify channel with Webgility applications.
Steps to fix:
Once you have access to the Shopify Admin Credentials, you need to reconnect the Sales Channel within your Webgility app.
If you’re a Webgility Desktop user, follow the steps in this helpful article on How to Test Your Store Connection in Webgility Desktop
If you’re a Webgility Online user, follow the steps in this helpful article on How to Test Your Store Connection in Webgility Online
While reconnecting Shopify it should allow you to update Webgility’s Third-party Shopify App. also. Once done then you can test the order download and other functionalities.
If the problem persists, contact Webgility Support for further assistance.