Store Procedure does not exist: SP_GetAllProfileSpecificDetails_Scheduler
This error may occur in Webgility Desktop while launching the application. This happens when the Webgility Desktop requires database reindexing. It usually indicates that a required stored procedure is missing or that the database needs maintenance. This article will guide you through resolving the issue by updating Webgility Desktop or running the UnifyDBUpgrade utility to optimize the database and restore smooth performance.
Error Message:
Cause of the issue:
This issue is not tied to a specific action in the application but it is related to the performance of Webgility Desktop’s database. This typically arises when the Webgility Desktop requires database reindexing. Over time, as data is inserted, updated, or deleted, indexes can become fragmented, leading to slower database performance. Reindexing helps restore the efficiency of the indexes by defragmenting them or completely rebuilding them which enhances the database performance.
Steps to fix the error:
Update Webgility Desktop Application:
If your Webgility Desktop application is not up to date, we recommend updating it to the latest version. You can do this by navigating to the ‘Check for updates’ section under the Help tab in the application or by visiting the Webgility Portal.
Follow the steps in this helpful article on How to Update Your Webgility Desktop Software
Run UnifyDBUpgrade:
If your Webgility Desktop is already running on the latest version then running UnifyDBUpgrade will help you to optimize the performance of the Webgility Desktop Database.
Follow the steps in this helpful article on How to Run DB Upgrade & Utility
Note: If you are running Webgility Desktop on any third-party cloud hosting environment then reach out to Webgility Support for further guidance.