Cannot access a disposed object. Object name: 'frmDashboard'
This article helps Webgility Desktop users integrated with QuickBooks Desktop resolve the error: “Cannot access a disposed object. Object name: 'frmDashboard'.” This issue is typically related to the performance of the Webgility Desktop database and may require updates to the software or database. Follow the steps below to identify the cause and resolve the error for smooth application performance.
Error:
Cannot access a disposed object. Object name: 'frmDashboard'
Cause of the issue:
This issue is not tied to a specific action in the application but it is related to the performance of Webgility Desktop’s database. This typically arises when the Webgility Desktop requires database reindexing. Over time, as data is inserted, updated, or deleted, indexes can become fragmented, leading to slower database performance. Reindexing helps restore the efficiency of the indexes by defragmenting them or completely rebuilding them which enhances the database performance.
Steps to fix:
- Make sure Webgility Desktop is running on the latest version. If required, then perform the upgrade. This should resolve the issue. Follow the steps in this helpful article: How to Update Your Webgility Desktop Software
- In case if Webgility Desktop is already running the latest version, then perform Webgility database upgrade. Follow the steps in this helpful article: How to Run DB Upgrade & Utility