Why is Syncing Product Updates Taking So Long?

Learn why syncing product updates may take a long time even if only a few products have updates.

Webgility Help Center avatar
Written by Webgility Help Center
Updated over a week ago

Why is syncing Product Updates taking so long?

This article covers all the generic steps that can be followed if the product syncing process takes a long time.

Symptoms:

  1. Syncing product updates takes a long time, even if only a few products have updates.

  2. Items are not synchronizing even after multiple attempts.

  3. Synchronized quantities of your marketplace items like Amazon (FBM), eBay, or Etsy is taking an extra long time, and the status of synced items shows In Progress.

  4. There may be issues with the Webgility Store Module Plugins such as Woocommerce & Magento.

Symptom #1:

Syncing product updates takes a long time, even if only a few products have updates.

Cause

The inventory sync compares all products before applying the changes. For instance, if you have 10,000 SKUs, Webgility Desktop must receive all SKUs from QuickBooks, then receive all SKUs from the store, and then compare the list for differences.

Resolution

  • Decrease the batch size of the product sync in Advanced Settings.

  • An excessive count of items can also cause throttling issues if the scheduler tries to download items frequently. To avoid this, increase the duration of the product sync option inside the Scheduler Settings if using the Scheduler.

Symptom #2:

Items are not synchronizing even after attempting multiple times

Cause

Internet Connection Bandwidth or Connectivity Issues can cause this.

Resolution

1). Please check your internet connection, if it is connected then check the speed and internet bandwidth.

2). The Product Sync process also depends on the system's performance. We have provided the System Performance Status feature inside the Webgility Desktop application.

You can also try to run the DBUpgrade tool, please refer to this article: How to Run DB Upgrade & Utility

Symptom #3

  1. Synchronized quantities of your marketplace items like Amazon (FBM), eBay, or Etsy is taking an extra long time, and the status of synced items shows In Progress.

Cause

Due to a heavy load on marketplace servers, it may take some time for the marketplace to update the products.

Resolution

Generally, once you sync the inventory quantity of items it takes 15-30 minutes to update the product’s quantity, price, etc. Reduce the batch size of the sync products.

Symptoms #4

There may be issues with the Webgility Store Module Plugins such as Woocommerce & Magento.

Cause

Outdated Webgility Store Module Plugin

Resolution

Update store module: The below-mentioned article can help you find the Store Module URL in Webgility:

Note: Please run the store module URL on a web browser. If your Store Module URL is customized, kindly DO NOT proceed with the upgrade and contact Webgility support instead. A customized module version always includes ‘-C’ after the version number, for ex, 343-C.

Antivirus:

Installed antivirus could be interfering with the settings and preventing the application from functioning properly. If this is the case, please make sure that the Webgility folder is included in the anti-virus exclusions list.

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