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ErrorCode : 6270 - Transactions with Inventory (QOH) products can't be dated earlier than the Inventory Start Date for the products.
ErrorCode : 6270 - Transactions with Inventory (QOH) products can't be dated earlier than the Inventory Start Date for the products.

ErrorCode : 6270 - Transactions with Inventory (QOH) products can't be dated earlier than the Inventory Start Date for the products.

David Pond avatar
Written by David Pond
Updated over a week ago

ErrorCode : 6270 - Transactions with Inventory (QOH) products can't be dated earlier than the Inventory Start Date for the products. To get this posted you must not use standard product under QuickBooks Sync Settings Inventory tab. You must change your sync settings and try again! Customer address updated in QuickBooks.

Overview:

In QuickBooks Online, the system restricts the sale of items to orders placed on or after the product's inventory start date. Attempting to sell an item before this designated date will result in QuickBooks being unable to generate the corresponding item.

Cause:

QuickBooks identified a corresponding item; however, the inventory start date is later than the sale date.

If you created the product with today's inventory start date, when you sync orders using Webgility Online, the order containing that item was set before today's date.

Solutions:

1). Navigate to Sales> Products and Services, then use the search bar to find the inventory item.

2). Once the inventory item is located, click the ▼ downward arrow symbol to reveal additional options, then click Adjust starting value. Read the warning and click Got it!

3). When the Inventory Starting Value popup page loads, adjust the As of date field to a date that is earlier than the date you wish to record the inventory transaction.

4). Select "Save & Close" and proceed to download the latest accounting data in Webgility Online from QuickBooks. For detailed guidance use the following help article link.
Download the Latest Data from QuickBooks in Webgility Online

5). Additionally, if you have been utilizing the "Standard Customer" option in Webgility Online for posting transactions, switch it to "Create New." Follow the steps outlined below:

6). Navigate to Settings> Accounting> Customers.

7). If the customer is not found, choose "New Customer" from the drop-down menu.

Click on "Save" to confirm the changes.

After these steps, please try to post the orders again and let us know if the issue persists. Feel free to contact us at support@webgility.com.

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