Error:
Connection to Quickbooks failed! Please try again. Possible Reason: The application trying to connect to Quickbooks is not supported while multiple instances of Quickbooks are running. - Webgility Extension
Cause:
This usually happens when there are multiple instances of Quickbooks Desktop application running OR there is a difference in the user permissions between Webgility Extension and Quickbooks Desktop.
Steps to rectify the issue:
1). On the machine-facing issue, kindly close all the existing instances of the Quickbooks Desktop application. Also from Task Manager> Details. Once done launch Quickbooks Desktop again and then test connection from Webgility Extension.
2). In case if the issue persists then this means that there is a difference in the user-level permissions between Webgility Extension and Quickbooks Desktop. So kindly follow the below steps:
Close both Webgility Extension as well as Quickbooks Desktop on the machine completely also from the Task Manager > Details tab.
Now go to C Drive and look for the Webgility folder, right-click on it, and go to Properties > Security tab > Edit > Add, in the Enter the object names to select text box, type the name of the user “Everyone” > check names > Ok > For Full Control > check the box under “Allow” > Apply > ok.
Refer to this help article for steps (LINK).
Need to follow the same above step for the Webgility Extension launcher, Intuit folder (C:\Program Files\Intuit\), and Quickbooks Desktop launcher.
Once done launch Quickbooks Desktop, then Webgility Extension, and then test the connection again.