Skip to main content
All CollectionsWebgility DesktopAdvice & troubleshootingOrder Posting Related
There is an invalid reference to Quickbooks Item "Avatax" in the SalesReciept line. Quickbooks error message: You cannot use the same tax item in both the line items and the txn tax.
There is an invalid reference to Quickbooks Item "Avatax" in the SalesReciept line. Quickbooks error message: You cannot use the same tax item in both the line items and the txn tax.

Learn how to solve "There is an invalid reference.....both the line items and the txn tax."

Devendra Singh avatar
Written by Devendra Singh
Updated over 2 weeks ago

Error:

There is an invalid reference to Quickbooks Item "Avatax" in the SalesReciept line. Quickbooks error message: You cannot use the same tax item in both the line items and the txn tax.


Cause of the issue:

This issue typically occurs while posting orders into QuickBooks. The error indicates that the same tax item, (ex."Avatax”) has been configured to record both taxable and non-taxable orders under Sales Tax settings in Webgility Desktop which is not allowed by QuickBooks. QuickBooks prevents the use of the same tax item in both places to avoid double taxation or confusion.


Steps to fix:

  • In your QuickBooks Desktop company file, make sure it has at least two unique Sales tax items, to record tax for both taxable and non-taxable orders.

  • Now in Webgility Desktop navigate to Connections, then goto Accounting/POS/ERP and then click on Sync Settings.

  • Navigate to Sales Tax and under Configure your sales tax you will be able to enable either of the below-mentioned options:

    • Let QuickBooks recalculate sales tax

    • Record sales tax calculated from Sales Channel as a line item in Quickbooks

But, both the above-mentioned options will ask you to configure separate tax item for both taxable and non-taxable orders.

  • So configure the required tax item under the taxable order option which is used to record the taxes on the transaction in your QuickBooks. Then configure another tax item under the non-taxable order option which is used to record zero tax on the transaction in your QuickBooks.

  • Once done then click on Save and Continue.

  • Now try to post the order again.


If the problem persists, contact Webgility Desktop for further assistance.

Did this answer your question?