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Error: Expenses Post to QuickBooks Failed" Due to Invalid Reference to QuickBooks Account
Error: Expenses Post to QuickBooks Failed" Due to Invalid Reference to QuickBooks Account

Error: Expenses Post to QuickBooks Failed" Due to Invalid Reference to QuickBooks Account

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Written by Virendra
Updated this week

Overview:

When posting an expense to QuickBooks, you may encounter the error: “Expenses posted to QuickBooks failed due to an invalid reference to the QuickBooks account.” This issue typically arises when there is a misconfigured bank account under the deposit settings.

Cause:

This error occurs because QuickBooks cannot match the bank account selected in the system to the correct one in your QuickBooks account. This can happen if the bank account is not set up correctly or if the wrong bank account is selected for deposits.

Steps to resolve:

To resolve this issue, you will need to update the bank account reference in the deposit setup. Follow these steps:

  • Log into the Webgility application, and navigate to the Connection Menu.

  • Click the Connection Menu “Account and Settings” from the dropdown menu.

  • Go to the Payments Section:

    • In the left-hand menu then click on the Sync Settings and go to the Expenses & Fees option, Click on Setup under the “Download Payouts” option.

  • Edit the Deposit Settings

    • Under the Deposit section, you will find the account selected for deposits. If this is incorrect, click on it and select the correct deposit account.

  • Select the Correct Bank Account

    • Choose the correct bank account from the list. This should match the account you wish to use for your expenses and payments.

  • Save Your Changes

    • After selecting the correct bank account, click “Save” to update your settings.

  • Reattempt Posting the Expense

    • Once the correct bank account is selected, try posting the expense to QuickBooks again. The issue should now be resolved.


If you have any questions or need more help, contact our support team.

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