There was an error when saving an Item Inventory list, element. QuickBooks error message: The inventory account is invalid
This article helps Webgility Desktop users to resolve the error “There was an error when saving an Item Inventory list, element. QuickBooks error message: The inventory account is invalid.” that may occur when creating items from Webgility Desktop into QuickBooks Desktop . This issue indicates that the accounts linked to the item setup in QuickBooks Desktop are inactive, missing, or invalid. The article explains how to verify the accounts in QuickBooks Desktop and refresh the accounting data in Webgility Desktop to successfully resolve the error.
Error Message:
There was an error when saving an Item Inventory list, element. QuickBooks error message: The inventory account is invalid.
Cause of the issue:
This error occurs when attempting to create items from Webgility Desktop into QuickBooks Desktop. The error indicates that the accounts linked to the item are not valid in QuickBooks Desktop. The error happens because the accounts being used for the item setup are either inactive, missing, or otherwise invalid. This can prevent the item from being created successfully, and QuickBooks Desktop will flag the account as invalid.
Steps to fix:
Verify the Accounts and download latest QuickBooks Desktop data into Webgility Desktop:
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Login into your Quickbooks with admin user and verify all the chart of accounts that you would like to use for creating new items.
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Now navigate to Webgility Desktop and download latest accounting data
Follow the steps in this helpful article on How to Download the Latest Accounting Data from Scratch
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Try to create the items again.