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Orders Not Posting to QuickBooks: "Index Was Out of Range. Must be Non-Negative and Less Than the Size of the Collection Parameter Name Index" Error

This article helps Webgility Desktop users resolve the error "Index Was Out of Range. Must be Non-Negative and Less Than the Size of the Collection Parameter Name Index" that occurs when posting orders into QuickBooks Desktop. The issue arises when Webgility Desktop does not have the most recent QuickBooks Desktop accounting data, leading to mismatched or incomplete information during order posting. By refreshing the accounting data, users can synchronize both systems and successfully complete the posting process.

Error:

"Index Was Out of Range. Must be Non-Negative and Less Than the Size of the Collection Parameter Name Index" Error

 
 

Cause of the issue:

This issue typically arises while posting orders into Quickbooks Desktop. This error indicated that the latest accounting data from Quickbooks Desktop has not been updated into Webgility Desktop


Steps to fix: