Connection to Quickbooks failed! Please try again. Possible Reason: The application trying to connect to Quickbooks is not supported while multiple instances of Quickbooks are running
Error:
Connection to Quickbooks failed! Please try again. Possible Reason: The application trying to connect to Quickbooks is not supported while multiple instances of Quickbooks are running. Webgility Extension
Cause:
This usually happens when there are multiple instances of the Quickbooks Desktop application running or there is a difference in the user permissions between the Webgility Extension and Quickbooks Desktop.
Steps to rectify the issue:
1). Restart QuickBooks Desktop:
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On the affected machine, close all instances of the QuickBooks Desktop application.
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Open Task Manager, go to the Details tab, and ensure there are no lingering QuickBooks processes.
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Once everything is closed, relaunch QuickBooks Desktop and test the connection from the Webgility Extension.
2). Check User-Level Permissions:
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If the issue persists, it may be due to a discrepancy in user permissions between the Webgility Extension and QuickBooks Desktop.
Follow these steps:
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Close both the Webgility Extension and QuickBooks Desktop completely, including the one under the Details tab in Task Manager.
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Navigate to the C: Drive and locate the Webgility folder.
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Right-click on the Webgility folder and select Properties.
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Go to the Security tab, click Edit, and then Add.
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In the Enter the object names to select text box, type Everyone, then click Check Names and OK.
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Under Permissions for Everyone, check the box for Full Control under the “Allow” column.
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Click Apply and OK to save the changes.
Please refer to the help article here for detailed instructions on how to execute the Unify.exe.
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Need to follow the same steps for the Webgility Extension launcher, Intuit folder (C:\Program Files\Intuit\), and the Quickbooks Desktop launcher).
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Once done launch Quickbooks Desktop, then Webgility Extension, and then test the connection again.
If you still need further assistance, please contact the Webgility Support Team.