Skip to main content
All CollectionsWebgility DesktopAdvice & troubleshootingOrder Posting Related
Post to QuickBooks failed due to an error when converting the price "-20.89" in the field "item cost".
Post to QuickBooks failed due to an error when converting the price "-20.89" in the field "item cost".

Post to QuickBooks failed due to an error

Virendra avatar
Written by Virendra
Updated over a week ago

Error:

Post to QuickBooks failed due to an error when converting the price "-20.89" in the field "item cost". QuickBooks error message: You can't use negative rates on inventory items, use neg quantity instead

Cause:

The error message suggests that QuickBooks is unable to accept a negative value for the "item cost" field when posting the order. Inventory items in QuickBooks cannot have negative prices, as this would imply that the company is paying customers to take their inventory. Instead, if you want to reflect a discount or reduction in cost, you should use a negative quantity instead of a negative price.

For example, if you have an inventory item with a cost of $10, and you want to give a $2 discount, you should enter a quantity of -1 and a cost of $10 in the order. This will result in a total cost of $8 for that item.

To resolve the error message, try adjusting the price to a positive value or using a negative quantity instead of a negative price. Additionally, make sure that the item cost field is filled out correctly and that there are no typos or incorrect information in the order.

Troubleshooting

  1. An item price should not be negative, QuickBooks will not allow posting a negative price for an inventory item.

  2. If possible fix the price on the sales channel itself and redownload the order again.

  3. If it’s not possible to change the price on sales channel then you will need to make sure the item with a negative price is not mapped/matched with an Inventory item.

  4. To fix the item in QB, please follow the below steps:

  • Copy the item SKU from the order

  • Go to the Products tab in Webgility> All products (under the sales channel on the left side) and search for the item.

  • Then on the top right change the View filter to Matched/Mapped so you can verify with which QB item this SKU has been mapped to.

  • If that item has been mapped with an inventory item then go to QB and change that item type to a non-inventory item.

  • Please follow the steps given in this Article

Try to post the order again it should now post. Please free to reach out to Webgility Support if you still need any assistance.

Did this answer your question?