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Shopify Partial Refund and Partial Refund Order Missing

This article explains Webgility Desktop users why Shopify partial refunds or partially refunded orders may not appear in Webgility Desktop. The issue occurs because Webgility Desktop downloads orders based on the configured order status in the store connection. By default, only open and closed orders may be retrieved. To resolve this, users need to adjust the Advanced Override Settings in Webgility Desktop to capture all relevant order statuses, ensuring that partial refunds and related orders are downloaded correctly.

Cause

In Webgility Desktop, you can apply a setting to either download open and closed orders, or override this setting in the Advanced Settings menu. To do this, select to download only Paid and Shipped and Paid and Unshipped orders.

Resolution

1. In Webgility Desktop, you will need to select all options from the advance override settings. To do this navigate to "Connections >> Sales Channels >> Advanced Settings.

2. Next, go to the Other tab. Enable the feature "Overwrite Shopify Order Download Settings" by checking the box. Then select UnPaid, UnPaid And Shipped, Paid and UnShipped, Paid And Shipped.  Then click on Save and Close.

3. Now navigate back to Dashboard, goto Get New Orders, select the required back date from which your order and refund are missing. Save & Close. Then click on Get New Orders. This will download all the missing orders for that period also will register refunds on the required  existing ones.