The debit and credit are not balanced. It seems some additional heads are not categorized in the settlements. Please save the Journal Settings again to accommodate that categorization.
This article helps users to resolve the error “The debit and credit are not balanced. It seems some additional heads are not categorized in the settlements.” that may occur when using to post settlement summaries as Journal Entries into QuickBooks Online via Webgility Online. It explains that the error happens when settlement data is incomplete or uncategorized, leading to an imbalance in debit and credit, and provides steps to correct the Journal Settings to fix the issue.
Error Message:
The debit and credit are not balanced. It seems some additional heads are not categorized in the settlements. Please save the Journal Settings again to accommodate that categorization.
Cause of the issue:
The issue typically occurs while summary postings (Journal Entries) into Quickbooks. The error indicates that there is a discrepancy in the settlement data resulting in an imbalance. This can happen due to missing or unclassified data in the settlement report.
Steps to fix:
Reverify the Summary Posting Settings:
In Webgility Online navigate to the Sync settings and go to Account Mapping then click on Refresh QuickBooks accounts. Once it is complete then verify and save the settings again.
Redownload the Settlement Report:
Now you can navigate back to Summary and go to Settlements tab. Now select the required settlement by checking the box and then go to More Actions dropdown at the bottom and select Refresh settlement(s) and click on OK.
Once done then try Summary Posting again.