Post to QuickBooks failed due to The string in the field of “PONumber” is too long
Learn how to solve error "Post to QuickBooks failed due to The string in the field of “PONumber” is too long"
Error:
Post to QuickBooks failed due to The string in the field of “PONumber” is too long
Cause of the issue:
This issue typically occurs when attempting to post an order to QuickBooks. The error indicates that the field mapped with the PO Number of QuickBooks exceeds the allowed character limit. In this case it is the Order notes associated with the order contains a string that is too long, which QuickBooks does not accept. QuickBooks imposes a character limit for fields like order notes, and if the order note exceeds this limit, QuickBooks will not allow the post to be completed.
Steps to fix:
1). In your Webgility Desktop, navigate to the required order
2). Open the order details by double mouse left clicking on the order.
3). Adjust the Order Note
In the order details, in the bottom right section to find the "Order Notes" field. Review and edit the order note to ensure the text fits within the allowable character limit for QuickBooks.
4). Save and Retry Posting
After reducing the order note size, save the changes and try posting to QuickBooks again.