Delete QuickBooks Transaction filed due to Cannot delete the object specified by the id. QuickBooks error message: Did not delete this transaction. This transaction had deposited payments.
This article helps Webgility Desktop users integrated with QuickBooks Desktop resolve the error: “Delete QuickBooks Transaction failed due to: Cannot delete the object specified by the id. QuickBooks error message: Did not delete this transaction. This transaction had deposited payments.” This error typically occurs when attempting to undo-sync an order from QuickBooks Desktop via Webgility Desktop. It indicates that the transaction is included in a deposit within QuickBooks, and it must be manually removed from the deposit before it can be deleted or unsynced.
Error Message:
Cause of the issue:
This error typically occurs when we attempt to undo-sync an order from QuickBooks Desktop in Webgility Desktop. According to the error message, there is a deposit associated with the order that needs to be manually deleted inside QuickBooks Desktop, in order to successfully undo-sync the order.
Steps to fix:
- Please navigate to QuickBooks Desktop and locate the associated deposit linked to the transaction, then proceed to delete it.
- After that, return to Webgility, select the order, right-click, and choose the "undo-sync" option. This action will successfully reverse the sync for the order.