"Error While Creating a Shipment: Missing Required Scopes"
This article helps Webgility Desktop users resolve errors encountered when posting orders to a sales channel via Webgility Desktop. These errors are often caused by expired authorization or insufficient app permissions. The guide outlines steps to reconnect the sales channel and, if necessary, remove and re-add the Webgility app such has Shopify channel to restore proper integration and ensure successful order posting.
Note: This article uses Shopify channel as example
Overview:
This error occurs when posting an order to the store and indicates that the application certificate or authorization does not have sufficient permissions or has expired.

Root Cause:
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Insufficient Permissions or Expired Authorization:
The app does not have the required permissions or its authorization has expired.
Steps to fix:
Step 1: Reconnect the Store
Reconnect the sales channel. Follow the steps in this helpful article on: How to update sales channel credentials in Webgility Desktop
Step 2: Remove and Re-add the Webgility App (If the Issue Persists)
If the issue is not resolved after reconnecting the store, follow these steps:
A). Remove the Webgility App from Shopify:
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Log in to your Shopify account.
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Go to Settings.
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Click on Apps and Sales Channels.
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Find Webgility QB Desktop Sync.
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Click the three dots next to the app and select Uninstall.


B). Reconnect the Store again:
- Reconnect the sales channel again and re-add the Webgility app to your Shopify store. Follow the steps in this helpful article on: How to update sales channel credentials in Webgility Desktop
- Once done then try to post to store again.