Error while creating refund for PayoutID, Error while creating check, Insufficient permission level to perform this action
This article helps Webgility Desktop users resolve the error “Error while creating refund for PayoutID, Error while creating check, Insufficient permission level to perform this action.” This error usually occurs due to permission-related issues in QuickBooks Desktop, especially when it is used in multi-user mode alongside Webgility Desktop.
Overview:
The error mentioned typically occurs due to permission-related issues with QuickBooks Desktop users, especially when QuickBooks Desktop is used in multi-user mode alongside Webgility Desktop.
Root cause:
Permissions issue, the user in Quickbooks Desktop is listed as an add-on user and may have restricted access
Step-by-Step Guide to Fix Error
1. Close Quickbooks Desktop on all the machines. Now on Webgility Desktop relaunch it and then manually choose the correct company file and hit open.

2. Now log in with the admin credentials in case of multi-user mode, and once QuickBooks Desktop is opened, make sure at the top of the pane (Admin) is visible along with the QuickBooks Desktop version.
3. Once QuickBooks Desktop is opened with admin credentials, relaunch the Webgility Desktop application and go to Orders > Shopify > Payouts, select the payout, and attempt to repost, and this time the payout should post successfully.